X
تبلیغات
رایتل

سناربو اموزش PBR

bahram یکشنبه 29 تیر‌ماه سال 1393 @ 07:14 ب.ظ چاپ

سلام  دوستان  

توی این پست  یه  سناریو  ساده  در  مورد PBR  یرو  با  هم بررسی  میکنیم :




بقیه  در  ادامه  مطلب 


 
ادامه مطلب...

DHCP سرور روی روترهای سیسکو

bahram شنبه 24 اسفند‌ماه سال 1392 @ 12:45 ب.ظ چاپ

MED یا متریک در BGP

bahram شنبه 23 آذر‌ماه سال 1392 @ 06:36 ب.ظ چاپ

توی این پست میخوام در مورد یکی از مهمترین attribute  های bgp  صحبت  کنم به نام MED  این attribute  در بین attribute  های bgp  ،  رتبه 6 رو داره یعنی bgp  برای انتخاب مسیر  یه سری  اولویت رو مد نظر  قرار میده که MED  در اولویت ششم هست 

این مشخصه یا attribute   روی  روت های  ورودی  به AS   ما تاثیر  میذاره  یعنی   مثلا شرکت ما   به دوتا ISP  لینک داره که 

وقتی  ما روی  روتر لبه خودمون    مقدار   MED  رو که به متریک  هم معروف هست  ست میکنیم  این مقدار  توسط  update message  ها به  روترهای  ISP  فرستاده میشه و   اونها  روت  ورودی  رو تشخیص  میدن  یعنی هر  مسیری که متریک کمتری  داشته باشه  به عنوان مسیر  ورودی  به AS  ما  انتخاب میشه :


  • MED can be used to advertise to your neighbors how they should enter your AS.
  • MED is exchanged between autonomous systems.
  • The lowest MED is the preferred path.
  • MED is propagated to all routers within the neighbor AS but not passed along any other autonomous systems.

به شکل  زیر  دقت کنید  فرض کنید که سازمان شما  در شکل AS 1  هست  شما از طریق  این Attribute  به  AS  های دیگه میگید که از  کدوم مسیر  وارد  AS  شما بشن 


bgp med topology

در این مثال روی  روترهای مرزی  julisn مقدار متریک 200  و روی  روتر jacob  مقدار متریک  300 ست شده است  این مقدار به  روتر john  از طریق update  مسیج اطلاع داده میشه  در نتیجه روتر john  مسیر  با متریک  کمتر  رو انتخاب میکنه که همون مسیر  روتر julian   میشه 

حالا چطور  این مقدار متریک  یا MED  روی  روترهای  سازمانی که در اختیار  ماست  پیکربندی کنیم :

به مثال دیگه ای  در این مورد توجه کنید : رو ی  روترهای شکل زیر   )jim  , john   نتورک 1.1.1.0/24   داخل  bgp   منتظر  شده است .



  • bgp as path prepend lab




  • Jim(config)#router bgp 1
    Jim(config-router)#neighbor 192.168.12.2 remote-as 2
    Jim(config-router)#network 1.1.1.0 mask 255.255.255.0
    John(config)#router bgp 1
    John(config-router)#neighbor 192.168.23.2 remote-as 2
    John(config-router)#network 1.1.1.0 mask 255.255.255.0
    Jack(config)#router bgp 2
    Jack(config-router)#neighbor 192.168.12.1 remote-as 1
    Jack(config-router)#neighbor 192.168.23.3 remote-as 1

    روتر jack  رو هم مثل دو روتر دیگه به قرار فوق   پیکر بندی میکنیم  تا اینجای کار  مشکلی  نیست و همه چیز  ارومه.

  • اگه  روتینگ تیبل bgp  رو روی  روتر jack  چک کنیم  دو مسیر  برای  رسیدن به نتورک 1.1.1.0/24  وجود  داره

بهترین مسیر  مسیر طریق  192.168.12.1 معرفی شده یعنی روتر jim  خوب  حالا اگه  قصد  ما این باشه که  AS2  از  طریق  روتر john  به شبکه 1.1.1.0/24   دسترسی  داشته باشه  اینه که متریک  این  مسیر  کمتر  باشه   برای این کار  ما باید بیاییم و یه روت مپ  واسه این روترها  بنویسیم  که  متریک  رو یه AS2   بفرسته  
روت  مپ رو به قرار  زیر  روی  روترها  مینویسیم


اول  یه  روت مپ تعریف کردیم به اسم  MED   بعد  متریک  رو  واسش  700 گذاشتیم  و وارد تنظیمات bgp   روی  روتر jim  میشیم و  واسه  اون  روتر همسایه که میخواهیم متریک  واسش  فرستاده بشه   تنظیمات رو انجام  میدیم
 


Jim(config)#route-map MED permit 10
Jim(config-route-map)#set metric 700   
Jim(config-route-map)#exit

Jim(config)#router bgp 1
Jim(config-router)#neighbor 192.168.12.2 route-map MED out
John(config)#route-map MED permit 10
John(config-route-map)#set metric 500
John(config-route-map)#exit

John(config)#router bgp 1
John(config-router)#neighbor 192.168.23.2 route-map MED out
پیکربندی  متریک  رو  واسه  روتر john  با مقدار متریک  دلخواه انجام  میدیم 

در  مرحله بعد اگه  روتینگ تیبل  روتر جک  رو چک  کنیم  مقدار  متریک  در روتینگ  تیبل  اونها  ست  شده  و بهترین  مسیر  با مقدار متریک کمتر  انتخاب  شده 




BGP Path Attribute

bahram جمعه 22 آذر‌ماه سال 1392 @ 09:17 ب.ظ چاپ

Policy routing

bahram چهارشنبه 20 شهریور‌ماه سال 1392 @ 09:42 ق.ظ چاپ

policy routing  یه مشخصه خیلی خوب در روترهای سیسکو است  که میتوان با استفاده از ان  مسیر  روتینگ را با ستفاده از  سیاست اعمالی توسط  ماتغییر داد  شبکه زیر  را در نظر  بگیرید .. در این شبکه  بین روتز ها پروتکل  روتینگ EIGRP  برقرار شده است  در حالت نرمال  مسیر یابی  شبکه 192.168.1.0  به سمت شبکه 192.168.45.0  از طریق  مسیر R1  R2  انجام میگیرد  چون این مسیر پهنای باند بیشتری  نسبت به مسیر R1 R3   دارد در این  مثال  ما میخواهیم مسیر  شبکه رو بر خلاف جدول  روتینگ EIGRP  تغییر بدیم  و مسیر  رو از  R1 R3  به سمت مقصد 192.168.45.0  هدایت کنیم  الیته  این کار  رو میشه  حتی برای یک  IP  حاص در شبکه هم انجام داد که بستگی به ACCESS LIST   داره که ما اعمال میکنیم

پهنای  باند مسیر R1 R2  1024 هست  و پهنای باند R1 R3  256 K 



لینک عکس برای نمایش بزرگتر :     http://s2.picofile.com/file/7931633973/pbr.jpg


بقیه در ادامه مطلب  


 
ادامه مطلب...

EIGRP LAB 01

bahram دوشنبه 11 شهریور‌ماه سال 1392 @ 02:45 ب.ظ چاپ

در ابن  سناریو  یه مرور تقریبا  کامل در مورد EIGRP  دارم   پس  سناریو رو تا اخر  دنبال کنید :

اهداف  این سناریو :

1- کانفیگ EIGRP 

2-authentication  in EIGRP 

3-route summrization

4-set gateway of last resort 

5-passive interface 





بقیه  در ادامه مطلب


 


ادامه مطلب...

HSRP

bahram یکشنبه 10 شهریور‌ماه سال 1392 @ 10:15 ب.ظ چاپ


HSRP مخفف Hot Standby Routing Protocol بوده و پروتکلی مخصوص شرکت سیسکو میباشد. از این پروتکل بمنظور افزونگی (redundancy) استفاده میشود.
استاندارد مشابهی به نام VRRP یا Virtual Router Redundancy Protocol نیز وجود دارد که سیسکو آن را نیز پشتیبانی میکند.
در تمام شبکه های محلی (LAN) تمام Host ها برای ارتباط با بیرون از شبکه از یک آدرس default gateway استفاده میکنند که اگر این default gateway دچار مشکل شود ارتباط شبکه با بیرون نا ممکن خواهد شد . با HSRP ما میتوانیم دو دستگاه روتر Gateway داشته باشیم : یکی فعال و دیگری به حالت انتظار (Standby) .تا چنانچه برای gateway فعال مشکلی پیش آمد،آن gateway که در حالت انتظار (Stand by ) است جای آن را بگیرد . در این حالت هر روتر دارای یک آدرس ip فیزیکی است که روی اینترفیسی که به lan متصل می شود تنظیم می گردد. اما همچنین هر دو روتر دارای یک آدرس ip مجازی (HSRP address) نیز هستند که به عنوان default gateway برای Host های Lan مورد استفاده قرار میگیرد.مهم نیست که کدام روترgateway (چه روتر فعال یا چه روتر standby یا پشتیبان) up باشند آدرس HSRP مجازی در هر حالت یکی است.



بقیه  در  ادامه  مطلب 

 


ادامه مطلب...

BGP LAB weight + Local pref

bahram یکشنبه 10 شهریور‌ماه سال 1392 @ 06:50 ب.ظ چاپ

توی  سناریو این پست  میخوام  در مورد 2 attribute  در bgp صحبت کنم  و این  دو رو  به همراه route -map   برای یه پرفیکس خواص پیاده کنم ،   با توجه به عکس  سناریو  4 AS   درنظر گرفته شده   که  هدف  از انجام این سناریو روتر 6  از طریق  روتر  5 بتونه به  سابنت  11.11.11.11  برسه   در ادامه  کانفیگ  روتر ها رو  برسسی  میکنیم :


هدف  از  این سناریو :  


1- یادگیری  EBGP 

2- یادگیری IBGP 

3- تمرین یادگیری  weight attribute 

4- تمرین یادگیری  LOCAL_PREF  

5- تمرین و یادگیری  Route- map 

6- تمرین EIGRP 





 


ادامه مطلب...

BGP Weight Attribute

bahram جمعه 8 شهریور‌ماه سال 1392 @ 06:09 ب.ظ چاپ

هدف از این سناریو پیاده سازی  weight attribute  در bgp   به همراهroute-map میباشد   


اهداف  :  روتر R1   به سابنت 172.16.4.0  از طریق  R3   

روتر R4  از طریق  R3    به نتورک 192.168.1.0 برسد



بقیه در ادامه مطلب  

 


ادامه مطلب...

BGP LAB 01 - Next Hop Self

bahram یکشنبه 3 شهریور‌ماه سال 1392 @ 01:11 ق.ظ چاپ

سلام به همه  دوستان عزیز امروز   در مورد  کاربرد  next hop self  در  bgp   صحبت خواهم کرد   کاربرد  این دستور  در  ibgp  هست  وقتی که یک route  از یک AS  دیگه وارد AS  ما میشه   و از طریق  روتر  اصلی  AS  به  روترهای  دیگر AS  فرستاده میشه روترهای دیگه AS   نمی توانند  روت خارجی  رو  ببینند  چون  ادرس  NEXT HOP  ان  تغییر  نکرده است    در ادامه  مرحله به مرحله پیش خواهم رفت  و توضیحات  لازم  رو میدم 




بقیه در ادامه مطلب 


 


ادامه مطلب...
تعداد کل : 11   1     2   >>