X
تبلیغات
رایتل

BGP LAB 01 - Next Hop Self

bahram یکشنبه 3 شهریور‌ماه سال 1392 @ 01:11 ق.ظ چاپ

سلام به همه  دوستان عزیز امروز   در مورد  کاربرد  next hop self  در  bgp   صحبت خواهم کرد   کاربرد  این دستور  در  ibgp  هست  وقتی که یک route  از یک AS  دیگه وارد AS  ما میشه   و از طریق  روتر  اصلی  AS  به  روترهای  دیگر AS  فرستاده میشه روترهای دیگه AS   نمی توانند  روت خارجی  رو  ببینند  چون  ادرس  NEXT HOP  ان  تغییر  نکرده است    در ادامه  مرحله به مرحله پیش خواهم رفت  و توضیحات  لازم  رو میدم 




بقیه در ادامه مطلب 


 

  

  • All IP addresses have been preconfigured as specified in the topology picture.
  • Configure IBGP between router Hansolo and Luke, use AS 100, use the loopback0 interfaces as source for BGP.
  • Configure EBGP between router Hansolo and Leia.
  • Ensure both BGP neighbor relationships are up.
  • Router HanSolo: Advertise the 192.168.12.0/24 network into BGP.
  • Router Leia: Advertise the 3.3.3.0 /24 on the loopback interface into BGP.
  • Ensure you can ping this network from router Hansolo.
  • Try to ping this network from router Luke, why does this fail?
  • Fix this problem by using a BGP command on router Hansolo. You are not allowed to advertise the 192.168.13.X network in BGP.

کانفیگ روترها  :


HANSOLO



!

interface Loopback0

 ip address 1.1.1.1 255.255.255.0

 

interface Serial0/0

 ip address 192.168.13.1 255.255.255.0

 serial restart-delay 0 

 

interface FastEthernet1/0

 ip address 192.168.12.1 255.255.255.0

 duplex auto

 speed auto

!

router ospf 1

 log-adjacency-changes

 network 1.1.1.0 0.0.0.255 area 0

 network 192.168.12.0 0.0.0.255 area 0

!

router bgp 100

 no synchronization

 bgp log-neighbor-changes

 network 192.168.12.0

 neighbor 2.2.2.2 remote-as 100

     این  دستورات جهت همسایه شده با روتر Luke میباشد            neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 next-hop-self

 neighbor 192.168.13.3 remote-as 200

 no auto-summary

!



چنانچه از دستور next-hop-self  در زوتر Hansolo  استفاده نشود  روتی که از سمت روتر  Leia  منتشر میشود  با همان next hop  به دست روتر Luke   خواهد رسید  


HanSolo(config-router)#neighbor 2.2.2.2 next-hop-self


روتینگ تبل  Luke  قبل از  اعمال  next-hop-self




روتینگ تبل  Luke بعد  از  اعمال  next-hop-self


Leia:



!

interface Loopback0

 ip address 3.3.3.3 255.255.255.0

!

interface Serial0/0

 ip address 192.168.13.3 255.255.255.0

 serial restart-delay  

 

router bgp 200

 no synchronization

 bgp log-neighbor-changes

 network 3.3.3.0 mask 255.255.255.0

 neighbor 192.168.13.1 remote-as 100

 no auto-summary



Luke:




!

interface Loopback0

 ip address 2.2.2.2 255.255.255.0

!

interface FastEthernet0/0

 ip address 192.168.12.2 255.255.255.0

 duplex auto

 speed auto

!

router ospf 1

 log-adjacency-changes

 network 2.2.2.0 0.0.0.255 area 0

 network 192.168.12.0 0.0.0.255 area 0

!

router bgp 100

 no synchronization

 bgp log-neighbor-changes

 neighbor 1.1.1.1 remote-as 100

 neighbor 1.1.1.1 update-source Loopback0

 no auto-summary

!



دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد