X
تبلیغات
رایتل

BGP LAB weight + Local pref

bahram یکشنبه 10 شهریور‌ماه سال 1392 @ 06:50 ب.ظ چاپ

توی  سناریو این پست  میخوام  در مورد 2 attribute  در bgp صحبت کنم  و این  دو رو  به همراه route -map   برای یه پرفیکس خواص پیاده کنم ،   با توجه به عکس  سناریو  4 AS   درنظر گرفته شده   که  هدف  از انجام این سناریو روتر 6  از طریق  روتر  5 بتونه به  سابنت  11.11.11.11  برسه   در ادامه  کانفیگ  روتر ها رو  برسسی  میکنیم :


هدف  از  این سناریو :  


1- یادگیری  EBGP 

2- یادگیری IBGP 

3- تمرین یادگیری  weight attribute 

4- تمرین یادگیری  LOCAL_PREF  

5- تمرین و یادگیری  Route- map 

6- تمرین EIGRP 





 

 

در  روتر  1    روتر را  کانفیگ  میکنیم  و لوپ بک های  0 و 1  را  درست کرده  و داخل  bgp   معرفی  میکنیم 



interface Loopback0

 ip address 11.11.11.11 255.255.255.0

!

interface Loopback1

 ip address 22.22.22.22 255.255.255.0

!

interface FastEthernet1/0

 ip address 10.0.12.1 255.255.255.0

 

interface FastEthernet1/1

 ip address 10.0.13.1 255.255.255.0


!

router bgp 1


 network 11.11.11.0 mask 255.255.255.0

 network 22.22.22.0 mask 255.255.255.0

        neighbor 10.0.12.2 remote-as 2

 neighbor 10.0.13.3 remote-as 3

 no auto-summary


تنظیمات  BGP   رو به صورت  فوق انجام داده  و با  روترهای  2 و3  همسایه میشود با  دستور  neighbor 



تنظیمات روتر 2 :



interface FastEthernet1/0

 ip address 10.0.12.2 255.255.255.0


interface FastEthernet1/1

 ip address 10.0.24.2 255.255.255.0


router bgp 2


 neighbor 10.0.12.1 remote-as 1

 neighbor 10.0.24.4 remote-as 4567


روتر  2 با  روتر 1 و روتر 4  بصورت فوق  همسایه میشود 


تنظیمات  روتر 3 :

interface FastEthernet1/0

 ip address 10.0.13.3 255.255.255.0

!

interface FastEthernet1/1

 ip address 10.0.35.3 255.255.255.0

!

router bgp 3


 neighbor 10.0.13.1 remote-as 1

 neighbor 10.0.35.5 remote-as 4567

روتر  3  با  روتر 1 و5  بصورت فوق  همسایه میشود 



تنطیمات  روتر 4 :




interface Loopback0

 ip address 4.4.4.4 255.255.25.0


interface FastEthernet1/0

 ip address 10.100.0.4 255.255.255.0


interface FastEthernet1/1

 ip address 10.0.24.4 255.255.255.0


قبل از انجام  تنظیمات bgp   ضروری  است که روترها همدیکر  را ببینند یعتی  قبل از ان لازم است که یک روت  ibgp  بین روترهای  داخل  AS   برقرار شود  لذا  در این   سناریو  از  EIGRP  استفاده شده است


router eigrp 1

 network 4.0.0.0

 network 10.0.0.0



router bgp 4567

جهت  همسایگی IBGP  بین  روترها در این سناریو از ادرس Loopback  روتر استفاده شده است لذا جهت این کار از درستور update source   استفاده شده است و همچنین  دستور  next-hop-self  استفاده شده که جهت انتشار  روت های خارجی  به داخل bgp  این دستور  ضروری میباشد ، هنگامی که روتر  یک روت خارجی  را از AS همشایه دریافت میکند اگر این دستور ست نشود با NEXT HOP  را  همان روتری که دریافت کرده قرار میدهد  لذا لازم است برای  انتشار  صحیح یک روت خارحی  به داخل ibgp  از این دستور  استفاده شود 

چون هدف از این  سناریو full mesh  میباشد  لذا   باید  با همه  روترهای  داخل  AS  باید  همسایگی  برقرار کند 


 neighbor 5.5.5.5 remote-as 4567

 neighbor 5.5.5.5 update-source Loopback0

 neighbor 5.5.5.5 next-hop-self


 neighbor 6.6.6.6 remote-as 4567

 neighbor 6.6.6.6 update-source Loopback0

 neighbor 6.6.6.6 next-hop-self


 neighbor 7.7.7.7 remote-as 4567

 neighbor 7.7.7.7 update-source Loopback0

 neighbor 7.7.7.7 next-hop-self



 neighbor 10.0.24.2 remote-as 2



تنظیمات  روتر 5 :



interface Loopback0

 ip address 5.5.5.5 255.255.255.0

!!

interface FastEthernet1/0

 ip address 10.100.0.5 255.255.255.0

!

interface FastEthernet1/1

 ip address 10.0.35.5 255.255.255.0

 !

router eigrp 1

 network 5.0.0.0

 network 10.0.0.0

 no auto-summary

!

router bgp 4567


 neighbor 4.4.4.4 remote-as 4567

 neighbor 4.4.4.4 update-source Loopback0

 neighbor 4.4.4.4 next-hop-self


 neighbor 6.6.6.6 remote-as 4567

 neighbor 6.6.6.6 update-source Loopback0

 neighbor 6.6.6.6 next-hop-self


 neighbor 7.7.7.7 remote-as 4567

 neighbor 7.7.7.7 update-source Loopback0

 neighbor 7.7.7.7 next-hop-self


 neighbor 10.0.35.3 remote-as 3




تنظیمات  روتر  6 : 


هدف  از انجام  این سناریو  این است که  روتر  6  از  طریق  روتر 4  به  نتورک  11.11.11.11  برسد  قبل از  انکه  با  ATTRIBUTE  وزن  این کار  رو انحام بدم    روتینگ تیبل  روتر  6   رو مرور  میکنیم :

همانطور که در شکل میبینید  روتر 6  از  طریق  روتر  5  به  نتورک  11.11.110 میرسد  لذا  میخواهیم  با استفاده از  weight مسیر  ان  را  تغییر  دهیم  




تنظیمات روتر  6 :


interface Loopback0

 ip address 6.6.6.6 255.255.255.0


interface FastEthernet1/0

 ip address 10.100.0.6 255.255.255.0


router eigrp 1

 network 6.0.0.0

 network 10.0.0.0

 no auto-summary

!

router bgp 4567


 neighbor 4.4.4.4 remote-as 4567

 neighbor 4.4.4.4 update-source Loopback0

 neighbor 4.4.4.4 next-hop-self


 neighbor 5.5.5.5 remote-as 4567

 neighbor 5.5.5.5 update-source Loopback0

 neighbor 5.5.5.5 next-hop-self

 neighbor 5.5.5.5 route-map test in

جهت اعمال  روت مپ  روی  همسایه ای که میخواهیم روت به ان فرستاده شود از  دستور  فوق  استفاده میکنیم  

 neighbor 7.7.7.7 remote-as 4567

 neighbor 7.7.7.7 update-source Loopback0

 neighbor 7.7.7.7 next-hop-self


در این  سناریو  رسیدن به  نتورک 11.11.11.0  مد نظر یوده  که از  روتر 4  عبور  کند  لذا  حهت این کار  ضروری  است که  حتما از یک  access list  یا  prefix-list  استفاده شود  در این  سناریو  از  prefix-list  استفاده شده است 


ip prefix-list net-11 seq 5 permit 11.11.11.0/24

!

route-map test permit 10

 match ip address prefix-list net-11

وزن  را  بصورت مقابل ست میکنیم        set weight 5000


بعد از  اعمال  دستورات فوق  روتینگ تیبل  روتر 6  بصورت مقابل  در می اید :




تنظیمات  روتر 7:



interface Loopback0

 ip address 7.7.7.7 255.255.255.0

!

interface FastEthernet1/0

 ip address 10.100.0.7 255.255.255.0

!

router eigrp 1

 network 7.0.0.0

 network 10.0.0.0

 no auto-summary

!

router bgp 4567


 neighbor 4.4.4.4 remote-as 4567

 neighbor 4.4.4.4 update-source Loopback0

 neighbor 4.4.4.4 next-hop-self

 neighbor 5.5.5.5 remote-as 4567

 neighbor 5.5.5.5 update-source Loopback0

 neighbor 5.5.5.5 next-hop-self

 neighbor 6.6.6.6 remote-as 4567

 neighbor 6.6.6.6 update-source Loopback0

 neighbor 6.6.6.6 next-hop-self


ادامه  دارد .........



دیدگاه های این نوشته : 1
دوشنبه 31 شهریور‌ماه سال 1393 , ساعت : 11:06 ق.ظ
بشکر ازمعلومات مزید شماه
امتیاز: 0 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد