X
تبلیغات
رایتل

Policy routing

bahram چهارشنبه 20 شهریور‌ماه سال 1392 @ 09:42 ق.ظ چاپ

policy routing  یه مشخصه خیلی خوب در روترهای سیسکو است  که میتوان با استفاده از ان  مسیر  روتینگ را با ستفاده از  سیاست اعمالی توسط  ماتغییر داد  شبکه زیر  را در نظر  بگیرید .. در این شبکه  بین روتز ها پروتکل  روتینگ EIGRP  برقرار شده است  در حالت نرمال  مسیر یابی  شبکه 192.168.1.0  به سمت شبکه 192.168.45.0  از طریق  مسیر R1  R2  انجام میگیرد  چون این مسیر پهنای باند بیشتری  نسبت به مسیر R1 R3   دارد در این  مثال  ما میخواهیم مسیر  شبکه رو بر خلاف جدول  روتینگ EIGRP  تغییر بدیم  و مسیر  رو از  R1 R3  به سمت مقصد 192.168.45.0  هدایت کنیم  الیته  این کار  رو میشه  حتی برای یک  IP  حاص در شبکه هم انجام داد که بستگی به ACCESS LIST   داره که ما اعمال میکنیم

پهنای  باند مسیر R1 R2  1024 هست  و پهنای باند R1 R3  256 K 



لینک عکس برای نمایش بزرگتر :     http://s2.picofile.com/file/7931633973/pbr.jpg


بقیه در ادامه مطلب  


 

تنظیمات روتر 1 : 

interface Serial2/0
 bandwidth 1024
 ip address 192.168.12.1 255.255.255.0

interface Serial2/1
 bandwidth 256
 ip address 192.168.13.1 255.255.255.0

router eigrp 1
 network 192.168.1.0
 network 192.168.12.0
 network 192.168.13.0
 no auto-summary

interface FastEthernet0/0
 ip address 192.168.1.250 255.255.255.0




R1(config)#route-map ccnp permit 10

R1(config-route-map)#match ip address 101

R1(config-route-map)#set interface serial 2/1





access-list 101 permit ip 192.168.1.0  0.0.0.255  192.168.45.0  0.0. 0.255

R1(config)#access-list 101 permit ip any any


R1(config)#int fa 0/0

R1(config-if)#ip policy route-map ccnp

ip policy زوی اینترفیس ورودی  روتر  ست میشه 

تنظینات روتر 2

interface FastEthernet0/1
 ip address 192.168.23.1 255.255.255.0

interface Serial1/0
 bandwidth 1024
 ip address 192.168.12.2 255.255.255.0



router eigrp 1
 network 192.168.12.0
 network 192.168.23.0
 no auto-summary

تتظیمات روتر 3 

interface FastEthernet0/1
 ip address 192.168.23.2 255.255.255.0

interface Serial1/0
 bandwidth 256
 ip address 192.168.13.2 255.255.255.0

router eigrp 1
 network 192.168.13.0
 network 192.168.23.0

 no auto-summary


تتظیمات روتر  4

interface FastEthernet0/0
 ip address 192.168.23.3 255.255.255.0


interface FastEthernet0/1
 ip address 192.168.45.1 255.255.255.0

router eigrp 1
 network 192.168.23.0
 network 192.168.45.0

 no auto-summary

در این سناریو ترافیک نتورک 192.168.1.0 به سمت 192.168.45.0  از روتر  R1 R3 عبور میکند  


دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد