X
تبلیغات
رایتل

BGP Weight Attribute

bahram جمعه 8 شهریور‌ماه سال 1392 @ 06:09 ب.ظ چاپ

هدف از این سناریو پیاده سازی  weight attribute  در bgp   به همراهroute-map میباشد   


اهداف  :  روتر R1   به سابنت 172.16.4.0  از طریق  R3   

روتر R4  از طریق  R3    به نتورک 192.168.1.0 برسد



بقیه در ادامه مطلب  

 

 

کانفیگ روتر R1 :



interface Loopback0

 ip address 1.1.1.1 255.255.255.255

!

interface Loopback1

 ip address 192.168.1.1 255.255.255.0

 ip ospf network point-to-point

!

interface FastEthernet0/0

 ip address 10.200.12.1 255.255.255.252

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 10.200.13.1 255.255.255.252

 clock rate 2000000


جهت برقراری IBGP  بین روترهای 1 , 2 لازم است که یک روتینگ پروتکل  بین  انها  راه اندازی شود در این سناریو از OSPF  استفاده شده است 


router ospf 1

 log-adjacency-changes

 network 1.1.1.1 0.0.0.0 area 0

 network 10.200.12.0 0.0.0.3 area 0

 network 192.168.1.0 0.0.0.255 area 0

!

router bgp 12

 no synchronization

 bgp log-neighbor-changes

 network 192.168.1.0

جهت همسایگی با  روتر 2  از  دستورت زیر  استفاده شده است 

 neighbor 2.2.2.2 remote-as 12

 neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 next-hop-self

پالیسی  روت مپ  چهت  دسترسی به نتورک 172.16.4.0  از طریق  روتر 3 بصورت زیر  نوشته شده است 


 neighbor 10.200.13.2 remote-as 3

        neighbor 10.200.13.2 route-map RM-WEIGHT in

 no auto-summary

!!


درابن  قسمت  نتورک 172.16.4.0 توسط یک پرفیکس  لیست مشخص شده است 

!

ip prefix-list NET-172 seq 5 permit 172.16.4.0/24

!

  در ابن قسمت یک نام  برای ROUTE-MAP  انتخاب شده است                route-map RM-WEIGHT permit 10

        در این قسمت  روت مپ  را با پرفیکس لیستی که در فوق درست کردیم  را مچ  میکنیم                      


     match ip address prefix-list NET-172

    با دستور  SET مقدار  وزن  انرا مشخص  کردیم                          set weight 100

!

route-map RM-WEIGHT permit 20



کانفیگ روتر R2 :



interface Loopback0

 ip address 2.2.2.2 255.255.255.255

!

interface Loopback1

 ip address 192.168.2.1 255.255.255.0

 ip ospf network point-to-point

!

interface FastEthernet0/0

 ip address 10.200.24.1 255.255.255.252

 duplex auto

 speed auto

!

interface FastEthernet0/1

 ip address 10.200.12.2 255.255.255.252

 duplex auto

 speed auto

!

router ospf 1

 log-adjacency-changes

 passive-interface Loopback0

 passive-interface Loopback1

 network 2.2.2.2 0.0.0.0 area 0

 network 10.200.12.0 0.0.0.3 area 0

 network 192.168.2.0 0.0.0.255 area 0

!

router bgp 12

 no synchronization

 bgp log-neighbor-changes

 network 192.168.2.0

 neighbor 1.1.1.1 remote-as 12

 neighbor 1.1.1.1 update-source Loopback0

 neighbor 1.1.1.1 next-hop-self

 neighbor 10.200.24.2 remote-as 4

 no auto-summary

!


کانفیگ روتر R3 :



!

interface Serial0/0

 ip address 10.200.34.1 255.255.255.252

 clock rate 2000000

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1

 ip address 10.200.13.2 255.255.255.252

 clock rate 2000000

!

router bgp 3

 no synchronization

 bgp log-neighbor-changes

 neighbor 10.200.13.1 remote-as 12

 neighbor 10.200.34.2 remote-as 4

 no auto-summary

!


کانفیگ روتر R4 :

روتر  R4  باید از  طزیق  روتر R3  به نتورک  192.168.1.0  برسد   


interface Loopback0

 ip address 172.16.4.1 255.255.255.0

!

interface FastEthernet0/0

 ip address 10.200.24.2 255.255.255.252

 duplex auto

 speed auto

!

interface Serial0/0

 ip address 10.200.34.2 255.255.255.252

 clock rate 2000000

!

interface FastEthernet0/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

interface Serial0/1

 no ip address

 shutdown

 clock rate 2000000

!

router bgp 4

 no synchronization

 bgp log-neighbor-changes

 network 172.16.4.0 mask 255.255.255.0

 neighbor 10.200.24.1 remote-as 12

 neighbor 10.200.34.1 remote-as 3

 neighbor 10.200.34.1 route-map RM-WEIGHT in

 no auto-summary

!!

!

ip prefix-list NET-1 seq 5 permit 192.168.1.0/24

!

route-map RM-WEIGHT permit 10

 match ip address prefix-list NET-1

 set weight 100

!

route-map RM-WEIGHT permit 20

!



در صورتی که بخواهید  weight  را  برای  یک همسایه  برای  تمام  update  ها  ست کنید  بصورت زیر  عمل  کنید :


router bgp 12


neighbor 192.168.12.2 weight 500


توجه  مهم :


در صورت استفاده از route-map  حتما  باید  از دستور  in  استفاده شود   در صورت استفاده از  route-map  و set   جهت ست کردن weight ، روتر  این کامند  را  قبول  نخواهد کرد  و حتما در جهت inbound   باید  ست شود  چون  وقتی  update  از  همسایه دریافت میشود با این کامند  روتر  میفهمه که  واسه روتی که از  روتر همسایه داره میاد  به اندازه ای که در  دستور  set  قرار دادیم  روتر  بیاد  مقدار weight  رو  در  BGP Table  افزایش میده 




دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد