X
تبلیغات
رایتل

MPLS TE

bahram دوشنبه 29 مهر‌ماه سال 1392 @ 04:15 ب.ظ چاپ

سلام  به همه دوستداران شبکه  امروز سرکار  یه سناریو پیاده کردم گفتم بذار  این جا  ملت استفاده کنن حالشو ببرن

سناریو  در مورد mpls te  رو بستر  IS-IS  هست   ترافیک مسیر  رفت  روی  تانل  به ترتیب زیر  باید عبود کنه : 

R6=> R5 =>R1 =>R3=> R2=> R7 => R9     

و مسیر برگشت  هم باید از یصورت  زیر  باشد :


R9=>R7=>R2=>R4=>R1=>R5=>R6


 مراحل کار به این صورت هستش که  ابتدا به امر  IGP  رو  باید  اکتیو کرد  بعد اون  فعال سازی CEF . و  همچنین  فعال سازی  MPLS traffic-eng  بصورت گلوبال  و  روی  روتینگ پروتکل  IGP  هست و در  اخر هم  تانل  ها رو باید  SETUP  کرد 




 لینک عکس  جهت نمایش بزرگتر 

http://s3.picofile.com/file/7978019993/mpls_te.gif

 





کانفیگ R1:


ip cef



mpls traffic-eng tunnels

!

!!!

interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 ip router isis 

 isis circuit-type level-2-only

! !!

interface FastEthernet1/0

 ip address 10.10.15.1 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet1/1

 ip address 10.10.12.1 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet2/0

 ip address 10.10.13.1 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet2/1

 ip address 10.10.14.1 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

!

router isis

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

 net 49.0001.0000.0000.0001.00

 is-type level-2-only

 metric-style wide


کانفیگ R2:


ip cef


mpls traffic-eng tunnels


interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 ip router isis 

 isis circuit-type level-2-only

 !


interface FastEthernet1/0

 ip address 10.10.12.2 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet1/1

 ip address 10.10.24.2 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet2/0

 ip address 10.10.23.2 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet2/1

 ip address 10.10.27.2 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

!

router isis

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

 net 49.0001.0000.0000.0002.00

 is-type level-2-only

 metric-style wide


کانفیگ R3:



ip cef


mpls traffic-eng tunnels

!


interface Loopback0

 ip address 3.3.3.3 255.255.255.0

 ip router isis 

 isis circuit-type level-2-only

 !

!

interface FastEthernet1/0

 ip address 10.10.13.3 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet1/1

 ip address 10.10.34.3 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet2/0

 ip address 10.10.23.3 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !


router isis

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

 net 49.0001.0000.0000.0003.00

 is-type level-2-only

 metric-style wide


کانفیگ R4:



ip cef

!

!

mpls traffic-eng tunnels

!

!

!!

!

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

 ip router isis 

 isis circuit-type level-2-only

 !

!!

interface FastEthernet1/0

 ip address 10.10.34.4 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet1/1

 ip address 10.10.24.4 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet2/0

 ip address 10.10.14.4 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!!

router isis

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

 net 49.0001.0000.0000.0004.00

 is-type level-2-only

 metric-style wide


کانفیگ R5:


ip cef

!multilink bundle-name authenticated

mpls traffic-eng tunnels

!!

interface Loopback0

 ip address 5.5.5.5 255.255.255.255

 ip router isis 

 isis circuit-type level-2-only

 !

!!

interface FastEthernet1/0

 ip address 10.10.56.5 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

interface FastEthernet1/1

 ip address 10.10.15.5 255.255.255.0

 ip router isis 

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 isis circuit-type level-2-only

 !

!

!

router isis

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng level-2

 net 49.0001.0000.0000.0005.00

 metric-style wide



کانفیگ R6:


ip cef
!

mpls traffic-eng tunnels
!!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
 !
!
interface Tunnel1
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 9.9.9.9
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit identifier 1
 !

interface FastEthernet1/0
 ip address 10.10.56.6 255.255.255.0
 ip router isis 
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 !!

router isis
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0006.00
 is-type level-2-only
 metric-style wide
!!
ip explicit-path identifier 1 enable
 next-address 10.10.56.5
 next-address 10.10.15.1
 next-address 10.10.13.3
 next-address 10.10.23.2
 next-address 10.10.27.7
 next-address 10.10.79.9


کانفیگ R7:

ip cef

mpls traffic-eng tunnels

interface Loopback0
 ip address 7.7.7.7 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
 !
interface FastEthernet1/0
 ip address 10.10.27.7 255.255.255.0
 ip router isis 
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 !
!
interface FastEthernet1/1
 ip address 10.10.78.7 255.255.255.0
 ip router isis 
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 !
!
interface FastEthernet2/0
 ip address 10.10.79.7 255.255.255.0
 ip router isis 
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 !
!
router isis
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0007.00
 is-type level-2-only
 metric-style wide
کانفیگ R9:


ip cef
mpls traffic-eng tunnels
!!
!
interface Loopback0
 ip address 9.9.9.9 255.255.255.255
 ip router isis 
 isis circuit-type level-2-only
 !
!
interface Tunnel1
 ip unnumbered Loopback0
 mpls traffic-eng tunnels
 tunnel mode mpls traffic-eng
 tunnel destination 6.6.6.6
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit identifier 1
 !
 no routing dynamic
! !
!
interface FastEthernet1/0
 ip address 10.10.79.9 255.255.255.0
 ip router isis 
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 isis circuit-type level-2-only
 !

router isis
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0009.00
 metric-style wide

ip explicit-path identifier 1 enable
 next-address 10.10.79.7
 next-address 10.10.27.2
 next-address 10.10.24.4
 next-address 10.10.14.1
 next-address 10.10.15.5
 next-address 10.10.56.6
 next-address 6.6.6.6



دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد