X
تبلیغات
رایتل

سناربو اموزش PBR

bahram یکشنبه 29 تیر‌ماه سال 1393 @ 07:14 ب.ظ چاپ

سلام  دوستان  

توی این پست  یه  سناریو  ساده  در  مورد PBR  یرو  با  هم بررسی  میکنیم :




بقیه  در  ادامه  مطلب 


  

در این  سناریو از  EIGRP   به  عنوان  روتینگ پروتکل IGP  استفاده شده  و  روتر ها  از این طریق  با یکدیگر  در  ارتباط  هستند 

هدف  این  سناریو اینه که  IP  های  که به سمت  نتورک  192.168.1.1 در  روتر  R1   میره  از  2  مسیر که  ما بصورت زیر   تعیین میکنیم  مسیر  یابی  بشه   PBR  یه جورایی  قوانین  مسیر  یابی  روتینگ پروتکل  رو به  شکل  دلخواه  ما  تغییر  میده  یعنی  ما  بهش  میگیم  که  از  کجا  بره  به  مقصد  برسه   در  این  سناریو  چون  پهنای   باند  مسیر   R2 , R3   و  همچنین  R2 , R1     مقدار 8 مگ   تظیم شده   بصورت  پیش  فرض  تمام  مسیر ها  از  R4  به  R1   از  طریق   R2  عبور  میکنه 


حالا  من  میخوام  روت های  نتورک    192.168.4.128/25  رو   عوض  کنم    و بگم  که از  مسیر    R4 -R3, R1    عبور  کنه 


برای  این کار   باید روی  روتر  R3   یه  اکسس  لیست  بنویسم که   نتورک  مورد  نظرم   رو  شامل  بشه  در  مرحل  بعد  هم بیام  یه  روت  مپ  بنویسم که  نکست هاپ  رو  برای   اکسس  لیست  ما   اینترفیس  سریال  S0/1  روتر  R1   قرار  بده .



در  زیر   تریس   نتورک های  روتر  5  تا  روتر  1   رو  میتونید ببینید :






تنظیمات   روتر  ها  بصورت  زیر هست :



R1:


interface Loopback1

 ip address 192.168.1.1 255.255.255.0

!!

interface Serial0/0

 bandwidth 8000

 ip address 172.16.12.1 255.255.255.248

 delay 16

 clock rate 8000000


!

interface Serial0/1

 bandwidth 4000

 ip address 172.16.13.1 255.255.255.248

 delay 32

 clock rate 2000000

!

interface Serial0/2

 no ip address

 shutdown

 clock rate 2000000

!

!

router eigrp 1

 passive-interface Loopback1

 network 172.16.0.0

 network 192.168.1.0

 no auto-summary

 eigrp router-id 1.1.1.1


!    



R2:

R2:


interface Loopback2

 ip address 192.168.2.1 255.255.255.0



interface Serial0/0

 bandwidth 8000

 ip address 172.16.12.2 255.255.255.248

 delay 16

 clock rate 2000000



interface Serial0/1

 bandwidth 8000

 ip address 172.16.23.2 255.255.255.248

 delay 16

 clock rate 4000000




router eigrp 1

 passive-interface Loopback2

 network 172.16.0.0

 network 192.168.2.0

 no auto-summary

 eigrp router-id 2.2.2.2



R3:


interface Loopback3

 ip address 192.168.3.1 255.255.255.0

!


interface Serial0/0

 bandwidth 4000

 ip address 172.16.13.3 255.255.255.248

 delay 32

 clock rate 4000000

!


interface Serial0/1

 bandwidth 8000

 ip address 172.16.23.3 255.255.255.248

 delay 16

 clock rate 2000000

!

interface Serial0/2

 bandwidth 4000

 ip address 172.16.34.3 255.255.255.248

 ip policy route-map rm-pbr-l5-R3-R1

 delay 32

 clock rate 4000000

!


router eigrp 1

 passive-interface Loopback3

 network 172.16.0.0

 network 192.168.3.0

 no auto-summary

 eigrp router-id 3.3.3.3



ip access-list standard acl-l5

 permit 192.168.4.128 0.0.0.127

!


route-map rm-pbr-l5-R3-R1 permit 10

 match ip address acl-l5

 set ip next-hop 172.16.13.1



R4:




interface Loopback4

 ip address 192.168.4.1 255.255.255.128

!

interface Loopback5

 ip address 192.168.4.129 255.255.255.128


interface Serial0/0

 bandwidth 4000

 ip address 172.16.34.4 255.255.255.248

 delay 32

 clock rate 2000000

!



router eigrp 1

 network 172.16.0.0

 network 192.168.4.0

 no auto-summary

 eigrp router-id 4.4.4.4




دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد