X
تبلیغات
رایتل

MPLS TE Per VRF

bahram شنبه 11 آبان‌ماه سال 1392 @ 12:35 ب.ظ چاپ

 توی این پست   تصمیم گرفتم که  یکی از  توپولوژی های  سایت gns3vault  رو  انجام  بدم  و اینجا  بذارم  سناریو مربوط به  مهندسی ترافیک در شبکه  MPLS  هست  شماتیک و کانفیگ  سناریو  بصورت  زیر  هست 



  


P1 CONFIG :


ip cef!


mpls traffic-eng tunnels

!

interface Loopback0

 ip address 4.4.4.4 255.255.255.255

 


interface FastEthernet1/0

 ip address 192.168.34.1 255.255.255.0

 mpls traffic-eng tunnels

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet1/1

 ip address 192.168.45.1 255.255.255.0

 mpls traffic-eng tunnels

 mpls label protocol ldp

 mpls ip

 !

 ip rsvp bandwidth 20000

!

!

router ospf 10

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

 log-adjacency-changes

 network 4.4.4.0 0.0.0.255 area 0

 network 192.168.0.0 0.0.255.255 area 0

!

mpls ldp router-id Loopback0

!


P2 CONFIG :



ip cef


mpls traffic-eng tunnels


interface Loopback0

 ip address 5.5.5.5 255.255.255.255

 !

!

interface FastEthernet1/0

 ip address 192.168.57.1 255.255.255.0

 mpls traffic-eng tunnels

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet1/1

 ip address 192.168.45.2 255.255.255.0

 mpls traffic-eng tunnels

 mpls label protocol ldp

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet2/0

 no ip address

 shutdown

 duplex auto

 speed auto

 !!

router ospf 10

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

 log-adjacency-changes

 network 5.5.5.0 0.0.0.255 area 0

 network 192.168.0.0 0.0.255.255 area 0

!

mpls ldp router-id Loopback0

!


P3 CONFIG :


ip cef


mpls traffic-eng tunnels


interface Loopback0

 ip address 3.3.3.3 255.255.255.255

 !

interface FastEthernet1/0

 ip address 192.168.36.1 255.255.255.0

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet1/1

 ip address 192.168.67.7 255.255.255.0

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls ip

 !

 ip rsvp bandwidth 20000

!

!!

!

router ospf 10

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

 log-adjacency-changes

 network 3.3.3.0 0.0.0.255 area 0

 network 192.168.0.0 0.0.255.255 area 0

!

mpls ldp router-id Loopback0



PE1  :


ip cef

!

!

ip vrf A

 rd 1:100

 route-target export 1:100

 route-target import 1:100

!

ip vrf B

 rd 1:200

 route-target export 1:200

 route-target import 1:200

!


mpls traffic-eng tunnels


interface Loopback0

 ip address 2.2.2.2 255.255.255.255

 !

!

interface Tunnel10

 ip unnumbered Loopback0

 mpls traffic-eng tunnels

 tunnel mode mpls traffic-eng

 tunnel destination 7.7.7.7

 tunnel vrf A

 tunnel mpls traffic-eng priority 1 1

 tunnel mpls traffic-eng bandwidth 20000

 tunnel mpls traffic-eng path-option 1 explicit identifier 1

 !

 no routing dynamic

!

interface Tunnel11

 ip unnumbered Loopback0

 mpls traffic-eng tunnels

 tunnel mode mpls traffic-eng

 tunnel destination 7.7.7.7

 tunnel vrf B

 tunnel mpls traffic-eng autoroute announce

 tunnel mpls traffic-eng path-option 1 explicit identifier 2

 !

 no routing dynamic

!

interface FastEthernet1/0

 ip address 192.168.34.2 255.255.255.0

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet1/1

 ip address 192.168.36.2 255.255.255.0

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls label protocol ldp

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet2/0

 ip vrf forwarding A

 ip address 192.168.12.1 255.255.255.0

 duplex auto

 speed auto

 !

!

interface FastEthernet2/1

 ip vrf forwarding B

 ip address 192.168.23.1 255.255.255.0

 shutdown

 duplex auto

 speed auto

 !

!

!

router ospf 20 vrf A

 log-adjacency-changes

 redistribute bgp 1 subnets

 network 192.168.12.0 0.0.0.255 area 0

!

router ospf 30 vrf B

 log-adjacency-changes

 network 192.168.23.0 0.0.0.255 area 0

!

router ospf 10

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

 log-adjacency-changes

 network 2.2.2.0 0.0.0.255 area 0

 network 192.168.0.0 0.0.255.255 area 0

!

router bgp 1

 no synchronization

 bgp log-neighbor-changes

 neighbor 7.7.7.7 remote-as 1

 neighbor 7.7.7.7 update-source Loopback0

 no auto-summary

 !

 address-family vpnv4

  neighbor 7.7.7.7 activate

  neighbor 7.7.7.7 send-community both

  neighbor 7.7.7.7 next-hop-self

 exit-address-family

 !

 address-family ipv4 vrf A

  no synchronization

  redistribute ospf 20 vrf A

 exit-address-family

!

!

ip explicit-path identifier 1 enable

 next-address 192.168.34.1

 next-address 192.168.45.2

 next-address 192.168.57.2

!

ip explicit-path identifier 2 enable

 next-address 192.168.36.1

 next-address 192.168.67.2

!

mpls ldp router-id Loopback0



PE2:



ip cef

!

!

ip vrf A

 rd 1:100

 route-target export 1:100

 route-target import 1:100

!

ip vrf B

 rd 1:200

 route-target export 1:200

 route-target import 1:200

!


mpls traffic-eng tunnels


interface Loopback0

 ip address 7.7.7.7 255.255.255.255

 !

!

interface Tunnel10

 ip unnumbered Loopback0

 mpls traffic-eng tunnels

 tunnel mode mpls traffic-eng

 tunnel destination 2.2.2.2

 tunnel vrf A

 tunnel mpls traffic-eng priority 1 1

 tunnel mpls traffic-eng bandwidth 20000

 tunnel mpls traffic-eng path-option 1 explicit identifier 1

 !

 no routing dynamic

!

interface Tunnel11

 ip unnumbered Loopback0

 mpls traffic-eng tunnels

 tunnel mode mpls traffic-eng

 tunnel destination 2.2.2.2

 tunnel vrf B

 tunnel mpls traffic-eng path-option 2 explicit identifier 2

 !

 no routing dynamic

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex half

 !

!

interface FastEthernet1/0

 ip address 192.168.67.2 255.255.255.0

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet1/1

 ip address 192.168.57.2 255.255.255.0

 duplex auto

 speed auto

 mpls traffic-eng tunnels

 mpls label protocol ldp

 mpls ip

 !

 ip rsvp bandwidth 20000

!

interface FastEthernet2/0

 ip vrf forwarding B

 ip address 192.168.78.1 255.255.255.0

 shutdown

 duplex auto

 speed auto

 !

!

interface FastEthernet2/1

 ip vrf forwarding A

 ip address 192.168.79.1 255.255.255.0

 duplex auto

 speed auto

 !

!

!

router ospf 20 vrf A

 log-adjacency-changes

 redistribute bgp 1 subnets

 network 192.168.79.0 0.0.0.255 area 0

!

router ospf 30 vrf B

 log-adjacency-changes

 network 192.168.78.0 0.0.0.255 area 0

!

router ospf 10

 mpls traffic-eng router-id Loopback0

 mpls traffic-eng area 0

 log-adjacency-changes

 network 7.7.7.0 0.0.0.255 area 0

 network 192.168.0.0 0.0.255.255 area 0

!

router bgp 1

 no synchronization

 bgp log-neighbor-changes

 neighbor 2.2.2.2 remote-as 1

 neighbor 2.2.2.2 update-source Loopback0

 neighbor 2.2.2.2 send-community both

 no auto-summary

 !

 address-family vpnv4

  neighbor 2.2.2.2 activate

  neighbor 2.2.2.2 send-community extended

  neighbor 2.2.2.2 next-hop-self

 exit-address-family

 !

 address-family ipv4 vrf A

  no synchronization

  redistribute ospf 20 vrf A

 exit-address-family

!

ip forward-protocol nd

no ip http server

no ip http secure-server

!

!

!

ip explicit-path identifier 1 enable

 next-address 192.168.57.1

 next-address 192.168.45.1

 next-address 192.168.34.2

!

ip explicit-path identifier 2 enable

 next-address 192.168.67.1

 next-address 192.168.36.2

!

!

!

!

!

!

mpls ldp router-id Loopback0

!




A1:


ip cef


interface Loopback0

 ip address 1.1.1.1 255.255.255.255

 !

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex half

 !

!

interface FastEthernet1/0

 ip address 192.168.12.2 255.255.255.0

 duplex auto

 speed auto

 !

!

interface FastEthernet1/1

 no ip address

 shutdown

 duplex auto

 speed auto

 !

!

!

router ospf 10

 log-adjacency-changes

 network 1.1.1.0 0.0.0.255 area 0

 network 192.168.12.0 0.0.0.255 area 0

!





A2:


ip cef

!

interface Loopback0

 ip address 9.9.9.9 255.255.255.255

 !


router ospf 10

 log-adjacency-changes

 network 9.9.9.0 0.0.0.255 area 0

 network 192.168.79.0 0.0.0.255 area 0

!


دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد