X
تبلیغات
رایتل

Inter Vlan Routing

bahram پنج‌شنبه 9 آبان‌ماه سال 1392 @ 09:20 ب.ظ چاپ


لبی که امروز قرار میدم Inter Vlan Routing هست با استفاده از سویچ لایه 3 ٰ در این LAB چهار vlan تعریف شده که استپ بای استپ پیش میریم



اول ترسیم توپولوژی هست باید بدونیم که چی میخواهیم توپولوژی که من در نظر گرفتم بصورت زیر هست 







لیتک عکس  برای  نمایش  بزرگتر

http://s4.picofile.com/file/7988597739/inter_vlan_routing.jpg




 

 





برای دیدن سایز بزرگ روی عکس کلیک کنید

نام:  3.jpg
مشاهده: 40
حجم:  67.3 کیلو بایت



بعد این مرحله باید vlan ها رو در ابتدا روی هر سویچ تعریف کنیم : بصورت زیر :


switch0(config)#vlan 10
switch0(config)#vlan 20

switch1(config)#vlan 10
switch1(config-vlan)#vlan 20
switch1(config-vlan)#vlan 30
switch1(config-vlan)#vlan 40

switch2(config)#vlan 30
switch2(config)#vlan 40


در مرحله بعدی باید تعریف کنیم که پورت های سویچ به کدام vlan ها دسرسی داشته باشند.... در switch0 پورتهای 0/1و0/2 به ترتیب به vlan های 10 و 20 دسرسی دارند و در سویچ 1 که عمل روتینگ رو واسه ما انجام میده همه vlan ها باید تعریف شود و در اخر در سویچ 2 نیز پورت های 0/2 و 0/3 به ترتیب به vlan 40 , 30 دسرسی دارند



در سویچ 0 :


switch0(config)#interface fastEthernet 0/1
switch0(config-if)#switchport mode access 
switch0(config-if)#switchport access vlan 10
switch0(config-if)#exit

switch0(config)#interface fastEthernet 0/1
switch0(config-if)#switchport access vlan 20
switch0(config-if)#switchport mode access 
switch0(config-if)#exit

و همچنین پورتی را که با سویچ لایه 3 در ارتباط است باید ترانک تعریف شود :


switch0(config)#interface fastEthernet 0/3
switch0(config-if)#switchport mode trunk 
switch0(config-if)#switchport trunk allowed vlan all


در سویچ 2


switch2(config)#interface fastEthernet 0/2
switch2(config-if)#switchport access vlan 30
switch2(config-if)#switchport mode access 


switch2(config)#interface fastEthernet 0/3
switch2(config-if)#switchport access vlan 40
switch2(config-if)#switchport mode access 

پورتی را که با سویچ لایه 3 در ارتباط است باید ترانک تعریف شود 


switch2(config)#interface fastEthernet 0/1
switch2(config-if)#switchport mode trunk 
switch2(config-if)#switchport trunk allowed vlan all

در این مرحله برای انجام عمل روتینگ نیاز هست که برای هر vlan در سویچ لایه 3 یک گیت وی تعریف شود برای این کار از اینترفیس vlan که یک اینترفیس مجازی هست رو به ازای هر vlan تعریف میکنیم و به هر کدام در رنج vlan مربوطه IP اختصاص میدهیم ٰ 


switch1(config)#interface vlan 10
switch1(config-if)#ip address 192.168.10.250 255.255.255.0

switch1(config-if)#interface vlan 20
switch1(config-if)#ip address 192.168.20.250 255.255.255.0

switch1(config-if)#interface vlan 30
switch1(config-if)#ip address 192.168.30.250 255.255.255.0

switch1(config-if)#interface vlan 40
switch1(config-if)#ip address 192.168.40.250 255.255.255.0

بعد از تعریف اینترفیس vlan ها در مرحله بعدی نیاز هست که پورت های ترانک رو تعریف کنیم ولی نکته ای که این جا لازمه که مورد توجه قرار داد ابتدا باید encapsulation رو روی اینترفیس مربوطه فعال کرد در غیر این صورت پورت ترانک نخواهد شد 
به دستور زیر دقت کنید :


switch1(config)#interface fastEthernet 0/1

switch1(config-if)#switchport mode trunk 
Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.


همونطور که میبینید سویچ این اجازه رو نمیده و ابتدا encapsulation رو بصورت زیر تعریف میکنیم 


switch1(config-if)#switchport trunk encapsulation dot1q 
switch1(config-if)#switchport trunk allowed vlan all 


اخرین مرحله کار فعال کردن عمل روتینگ روی سویچ لایه 3 هست که برای این کار از کامند زیر استفاده میکنیم 


switch1(config)#ip routing


توجه داشته باشید که این دستور فقط در سویچ لایه 3 استفاده میشه


دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد