X
تبلیغات
رایتل

Route redistribution and Route filtering

bahram شنبه 2 شهریور‌ماه سال 1392 @ 09:39 ب.ظ چاپ

توی سناریو این  پست  Router Redistribution  و  Route Filtering   رو همزمان  در یک  سناریو  با هم ازمایش  میکنیم 





کانفیگ روتر ها در ادامه مطلب   


http://s4.picofile.com/file/7907112361/topology.png


R1 l


!

interface Loopback1

 ip address 192.168.10.1 255.255.255.0

!

interface Loopback2

 ip address 192.168.11.1 255.255.255.0

!

interface Loopback3

 ip address 192.168.12.1 255.255.255.0

!

interface Loopback4

 ip address 192.168.13.1 255.255.255.0

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex half

!

interface FastEthernet1/0

 ip address 10.10.1.1 255.255.255.0

 ip ospf network broadcast

 duplex full

!

router ospf 1

 log-adjacency-changes

 redistribute rip subnets route-map test

 network 10.10.1.0 0.0.0.255 area 0

!

router rip

 version 2

 network 10.0.0.0

 network 192.168.10.0

 network 192.168.11.0

 network 192.168.12.0

 network 192.168.13.0

 no auto-summary

!

ip classless

no ip http server

no ip http secure-server

!

!

!

logging alarm informational

access-list 1 deny   192.168.13.0 0.0.0.255

access-list 1 permit any

!

route-map test permit 1

 match ip address 1

!

!

 



R2 :



interface Loopback1

 ip address 172.10.10.1 255.255.255.0

!

interface Loopback2

 ip address 172.10.11.1 255.255.255.0

!

interface Loopback3

 ip address 172.10.12.1 255.255.255.0

!

interface Loopback4

 ip address 172.10.13.1 255.255.255.0

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex half

!

interface FastEthernet1/0

 ip address 10.10.1.2 255.255.255.0

 ip ospf network broadcast

 duplex auto

 speed auto

!

interface FastEthernet1/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

router eigrp 1

 network 172.10.0.0

 no auto-summary

!

router ospf 1

 log-adjacency-changes

 redistribute eigrp 1 subnets route-map eigrp->ospf

 network 10.10.1.0 0.0.0.255 area 0

!

ip classless

no ip http server

no ip http secure-server

!

!

!

!

ip prefix-list test seq 5 deny 172.10.10.0/24

ip prefix-list test seq 10 permit 0.0.0.0/0 le 32

logging alarm informational

!

route-map eigrp->ospf permit 10

 match ip address prefix-list test

!




R3 :



!

interface Loopback1

 ip address 120.1.1.1 255.255.255.0

!

interface Loopback2

 ip address 120.1.2.1 255.255.255.0

!

interface Loopback3

 ip address 120.1.3.1 255.255.255.0

!

interface Loopback4

 ip address 120.1.4.1 255.255.255.0

!

interface FastEthernet0/0

 no ip address

 shutdown

 duplex half

!

interface FastEthernet1/0

 ip address 10.10.1.3 255.255.255.0

 ip ospf network broadcast

 duplex auto

 speed auto

!

interface FastEthernet1/1

 no ip address

 shutdown

 duplex auto

 speed auto

!

router ospf 1

 log-adjacency-changes

 network 10.10.1.0 0.0.0.255 area 0

 network 120.1.1.0 0.0.0.255 area 0

 network 120.1.2.0 0.0.0.255 area 0

 network 120.1.3.0 0.0.0.255 area 0

 network 120.1.4.0 0.0.0.255 area 0

!

ip classless

no ip http server

no ip http secure-server

!

!



دیدگاه های این نوشته : 0
برای نمایش آواتار خود در این وبلاگ در سایت Gravatar.com ثبت نام کنید. (راهنما)

نام :
ایمیل :
وب/وبلاگ :
ایمیل شما بعد از ثبت نمایش داده نخواهد شد